Plugin Updates – Activity Log, Apocalypse Meow, BackUpWordPress, and Captcha

wordpress plugin updatesShort List of Plugin Updates

A few recent plugin updates have been made over the last few weeks. This list below is a just a small list that includes several of the more commonly used ones that you will encounter. There have been a couple of general updates as well as a handful of exploit fixes.

Take note regarding the Captcha plugins has an important note for WooCommerce users which could cause some serious problems.

As always make sure that you are updating your plugins on a regular basis.

Activity Log

Still one of the easiest activity loggers for your WordPress sites. While not fully tested with WordPress 4.6, I have yet to encounter any problems with it on site that use it. The authors continue to make regular updates and only have a handful of open tickets. Hopefully we will see some additional updates for this plugin to cover any comparability issues that might arise. Still on our go to list of plugins to use for additional help securing your site.

2.3.3

  • Fixed! – Minor XSS vulnerability, credit to Han Sahin

2.3.2

  • Fixed! – Minor XSS vulnerability, credit to Han Sahin

 

Apocalypse Meow

So many security plugins have come passed our desks yet this is one of the few who actually have some features we love. Apocalypse Meow is one of the few that we have encountered that includes Password Strength enforcement for users as well as the ability to force a password reset to them as well. While it is not the biggest security plugins out there it does have a good foothold on becoming one with only 4 total support tickets in the last 2 months.

  • Author: Blobfolio, LLC
  • Last Updated: 8-29-2016
  • Requires: 4.4+ or higher
  • Compatible up to: 4.6
  • Average 5-Star Rating: 5

20.1.5

  • Option to mitigate phishing attempts with rel=noopener.
  • Additional common password checks.
  • Misc admin area improvements.

20.1.4

  • Show number of remaining attempts after login failure.
  • Fix failed login attempts not always expiring.

20.1.3

  • Fix layering bug that can make the Settings > Save button unclickable.

 

BackUpWordPress

Another great plugin to handle your WordPress site backups. BackupWordpress has been a great plugin over the years. The authors have been hard working well to keep up with any issues that might arise. While I still use this plugin on selected sites, I have run into some issues with it automatically running scheduled backups. As this plugin is not presently tested for comparability with 4.6 I will wait to see if it gets resolved.

 

  • Author: Human Made Limited
  • Last Updated: 8-2-2016
  • Requires: 3.9+ or higher
  • Compatible up to: 4.53
  • Average 5-Star Rating: 4

3.6.2 / 2016-08-02

  • Improves admin performance.
  • Improves security in internationalised strings.

3.6.1 / 2016-04-26

  • Bug fixes/improvements in disk space calculation
  • Misc bug fixes

 

On a side note of backup plugins we will be testing additional plugins to see if we like another option moving forward. One main aspect of backups is to have an offsite redundant copy. With all the new file storage mediums, such as Google Drive or OneBox, having that additional safety could prove to be a blessing in the event a site get hacked.

 

Captcha by BestWebSoft

Several new welcomed options have now come to the Captcha Plugin. Most notably the ability to shortcode captcha as well as form specific settings. A handful of other updates round out the recent updates by BestWebSoft. This has been by far the longest running captcha plugin for WordPress.

IMPORTANT NOTE FOR WOOCOMMERCE USERS: There may be an issue with WooCommerce and Captcha not playing nice together at the moment. A quick run through the support forum turns up this issue:

UserL jjbte writes:

Login Allowed Even When Captcha Answer is Incorrect

I have WooCommerce running on one site and that site is having an issue. When I log in to WordPress (Admin, etc.), the login is allowed even when I answer the Captcha problem incorrectly. This problem does not exist on another site running similar plugins (but not WooCommerce) and the same theme.

Check out the full ticket here: https://wordpress.org/support/topic/login-allowed-even-when-captcha-answer-is-incorrect/

 

  • Author: BestWebSoft
  • Last Updated: 8-18-2016
  • Requires: 3.8+ or higher
  • Compatible up to: 4.6
  • Average 5-Star Rating: 4.5

V4.2.4 – 18.08.2016

  • Bugfix : The bug with the update of the plugin database has been fixed.

V4.2.3 – 15.08.2016

  • NEW : An ability to choose own CAPTCHA settings for each form which is compatible with the plugin.
  • NEW : An ability to expand the list of forms which are compatible with the plugin via WordPress hooks.
  • NEW : An ability to show the CAPTCHA after the page is loaded.
  • NEW : The “bws_captcha” shortcode is added.
  • Update : The HTML structure of the plugin settings page has been updated.
  • Update : The Chinese language file has been updated (thanks to TIM).
  • Update : BWS panel section has been updated.
  • Bugfix : The bug with displaying CSS ID for the CAPTCHA block has been fixed.

V4.2.2 – 15.07.2016

  • Update : BWS panel section was updated.